ClusterCS v2.07 Update

ClusterCS has reached the 2.07 version and we are happy to present you what’s new.

In this update, we are focused on bringing software updates and bugfixes.

Updates:

ClusterCS has received an infrastructure upgrade to ensure improved stability and performance.

Proftpd

Updated to proftpd-1.3.6 + TLS for CentOS 6 , Amazon Linux AMI , Amazon Linux 2
Added TLS for proftpd in CentOS 7

Memcached

Improved memcached security by allowing only IPs from the cluster members to connect to it

OPcache

Added configuration options for OPcache in PHP setups:

  • opcache.memory_consumption
  • opcache.interned_strings_buffer
  • opcache.max_accelerated_files
  • opcache.validate_timestamps
  • opcache.save_comments
  • opcache.fast_shutdown

date.timezones

Restructured the Date.Timezones list for PHP with common timezones first

Apache

httpd-2.4.39 has been added due to an important security bug in previous versions

Bugfixes:

  • Let’s Encrypt – Auto-renewing fixed by agent updates
  • Fixed spamassassin using too many resources
  • Let’s Encrypt certificates are correctly generated on servers with more than one load balancer (And more than 1 type A DNS record)
  • An issue on removing a SPEED rule
  • Cluster-member server sometimes missing firewall rules

Let us know what you think of this update and if you don’t have an account, give it a try!